Resolved
Our upstream provider has fully resolved the underlying latency issues. We have confirmed that customer booking speeds have returned to normal across the Teebly mobile app and booking portals.
Monitoring
We are seeing significant improvements in system performance as our upstream provider stabilizes. Booking flow latency is returning to normal levels, and customers should experience much faster checkout times.
We are continuing to monitor the situation closely to ensure that performance remains stable.
Identified
We have identified that the increased latency in the customer booking flow is due to a performance issue with an upstream service provider.
Current Impact: Customers may experience slow loading times during checkout. We are working closely with the provider to resolve these delays. All bookings remain functional, and we will update you as soon as normal processing speeds are restored.