Resolved
This issue has been resolved. All systems are operating normally. If you continue to experience issues please try refreshing your session or contact our support team.
Identified
We are aware of a service interruption with an upstream provider impacting Business Dashboard authentication. You may be unable to sign in or modify user roles at this time. This outage also impacts creating new IFTTT connections.
Note: All customer-facing booking portals and the Teebly mobile app remain fully operational. Your customers can continue to book as normal.
We are monitoring the provider's progress and will provide updates as soon as service is restored.